您好,歡迎訪問深圳市蘇山偉達通訊設備有限公司官方網站!

致力于智慧城市、XPON光網絡通信工程

提供從產品到通信規劃設計方案的服務
服務熱線:

0755-89605209

首頁 > 新聞資訊 > 業界資訊 >

華為交換機三種劃分vlan的方法

【發布時間:2018-02-27 16:44:59】

在學習劃分vlan前,必須要了解華為交換機的端口類型:

Access類型端口

執行命令port default vlan vlan-id,將端口加入到指定的VLAN中。如果需要批量將端口加入VLAN,可在VLAN視圖下執行命令port interface-type { interface-number1 [ to interface-number2 ] } &向VLAN中添加一個或一組端口。

 

Trunk類型端口

– 執行命令port trunk allow-pass vlan { { vlan-id1 [ to vlan-id2 ] } &| all },將端口加入到指定的VLAN中。
–(可選)執行命令port trunk pvid vlan vlan-id,配置Trunk類型接口的缺省VLAN。


Hybrid類型端口

– 選擇執行其中一個步驟配置Hybrid端口加入VLAN的方式:
– 執行命令port hybrid untagged vlan { { vlan-id1 [ to vlan-id2 ] } &| all },將Hybrid端口以Untagged方式加入VLAN。Untagged形式是指端口在發送幀時會將幀中的Tag剝掉,適用于以太網端口直接與終端連接。
– 執行命令port hybrid tagged vlan { { vlan-id1 [ to vlan-id2 ] } &| all },將Hybrid端口以Tagged方式加入VLAN。Tagged形式是指端口在發送幀時不將幀中的Tag剝掉,適用于以太網端口與另一臺交換機設備的端口連接。


–(可選)執行命令port hybrid pvid vlan vlan-id,配置Hybrid類型接口的缺省VLAN ID。

缺省情況下,所有端口加入的VLAN和缺省VLAN都是VLAN1。

 

一、基于端口的vlan

組網需求
如圖1所示,某企業的交換機連接有很多用戶,且相同業務用戶通過不同的設備接入企業網絡。為了通信的安全性,也為了避免廣播報文泛濫,企業希望業務相同用戶之間可以互相訪問,業務不同用戶不能直接訪問。
可以在交換機上配置基于端口劃分VLAN,把業務相同的用戶連接的端口劃分到同一VLAN。這樣屬于不同VLAN的用戶不能直接進行二層通信,同一VLAN內的用戶可以直接互相通信。


 

操作步驟

步驟1 在SwitchA創建VLAN2和VLAN3,并將連接用戶的端口分別加入VLAN。SwitchB配置與SwitchA類似,不再贅述。
system-view
[Quidway] sysname SwitchA
[SwitchA] vlan batch 2 3
[SwitchA] interface ethernet 0/0/1
[SwitchA-Ethernet0/0/1] port link-type access
[SwitchA-Ethernet0/0/1] port default vlan 2
[SwitchA-Ethernet0/0/1] quit
[SwitchA] interface ethernet 0/0/2
[SwitchA-Ethernet0/0/2] port link-type access
[SwitchA-Ethernet0/0/2] port default vlan 3
[SwitchA-Ethernet0/0/2] quit

步驟2 配置SwitchA上與SwitchB連接的端口類型及通過的VLAN。SwitchB配置與SwitchA類似,不再贅述。

[SwitchA] interface ethernet 0/0/3
[SwitchA-Ethernet0/0/3] port link-type trunk
[SwitchA-Ethernet0/0/3] port trunk allow-pass vlan 2 3

步驟3 驗證配置結果將User1和User2配置在一個網段,比如192.168.100.0/24;將User3和User4配置在一個網段,比如192.168.200.0/24。

User1和User2能夠互相ping通,但是均不能ping通User3和User4。User3和User4能夠互相ping通,但是均不能ping通User1和User2。

 

 二、基于MAC地址劃分Vlan

組網需求
某個公司的網絡中,網絡管理者將同一部門的員工劃分到同一VLAN。為了提高部門內的信息安全,要求只有本部門員工的PC才可以訪問公司網絡。如圖2所示,PC1、PC2、PC3為本部門員工的PC,要求這幾臺PC可以通過SwitchA、Switch訪問公司網絡,如換成其他PC則不能訪問??梢耘渲没贛AC地址劃分VLAN,將本部門員工PC的MAC地址與VLAN綁定,從而實現該需求。


? selao在线精品